Hosthis - Cloudflare outage – Incident details

All systems operational

Cloudflare outage

Resolved
Major outage
Started about 1 month agoLasted about 9 hours
Updates
  • Resolved
    Resolved

    The issue has been resolved. We thank our clients for their patience and apologise for any inconvenience caused.

  • Investigating
    Investigating

    There's an outage in Cloudflare that resulted in a major outage to our payment API and client area.